XIAOMI Mi Pflanzensensor mit FHEM verbinden

Zuerst muss man den Xiaomi Flower Mate – Pflanzensensor vorsichtig öffnen und das Gerät durch entfernen der Plastiklasche zwischen Batterie und Gerät aktivieren. Da der Pflanzensensor nur mit einer chinesischen Anleitung kommt und wohl einige die Piktogramme nicht verstehen oder die englische Anleitung im Internet nicht finden (http://files.xiaomi-mi.com/files/plants_monitor/Plants_monitor-EN.pdf) ist das der häufigste Fehler für angeblich „defekte“ Sensoren. Der zweit häufigste Fehler ist, dass man eine chinesische Version und nicht die internationale Version gekauft hat. Dann muss in der Xiaomi App als Standort „China Mainland“ ausgewählt werden und zur aktivierung eine Chinesische IP -Adresse und eine chinesische GPS Position vorgegaukelt werden:

  1. Man benötigt ein Android Device
  2. Am besten alle anderen Apps schließen da später die Daten über einen chinesischen VPN laufen werden
  3. Ganz normal in der App mit dem eigenen Mi account anmelden
  4. Device in den Flugzeugmodus versetzten
  5. Das W-Lan wieder aktivieren
  6. Aus dem PlayStore die App FakeGPS App installieren (Sie kann eine falsche GPS-Position simulieren)
  7. Die App öffnen und die Position auf irgendwo auf dem Chinesischen Festland setzten und starten
  8. Aus dem PlayStore die App FlyVPN App installieren
    Die App starten und einen Chinesischen Server auswählen (keine registrierung notwendig) und das VPN starten
  9. Die Xiaomi Flower App starten und die FlowerCare Sensoren ganz normal verbinden, die Pflanzen auswählen und Firmware updaten
  10. Dann das VPN beenden, FakeGPS beenden.

Die Sensoren sind jetzt mit dem Xiaomi Account verknüpft. Diese Prozedur ist nur bei der ersten Inbetriebnahme durchzuführen. Jetzt funktionieren die Sensoren auch ohne VPN&Co.
(Dies ist nur für die Nutzung in der Xiaomi App notwendig, z.B. für Firmwareupdates. FHEM ist es egal welche Version verwendet wird. FHEM kann komplett ohne eine APP auf den Sensor zugreifen.).

Wenn man diese Hürde genommen hat ist der Sensor eigentlich bereit mit FHEM verknüpft zu werden. Allerdings bietet es sich an die Firmware auf dem Sensor auf die aktuelle Version zu updaten. Das ist entweder mit der Mi Home App (iOS), Mi Home App (Android) oder der Flower Care App (Android) (von Beijing HHCC Plant Technology Co., Ltd) über ein Bluetooth fähiges Smartphone/Tablet möglich.  Wenn man nur die Pflanzensensoren vom Mi im Einsatz hat, reicht die Flower Care App aus. Für beide Apps, die sehr viel Berechtigungen wollen, ist ein Mi Account nötig. Den Mi Account kann man eigentlich nur mit einer @gmail.com E-Mail Adresse eröffnen, alle anderen Adressen wurden mit nicht Zustellung der Betätigungsemail ohne Warnung oder Angabe von gründen nicht akzeptiert. Es kommt also einfach keine E-Mail in der Ihr das Konto bestätigen könnt. Wenn man sich dann endlich in der App eingeloggt hat kann mit + (oben rechts) nach Sensoren suchen und dann wird auch direkt das Firmwareupdate angeboten.

Dann geht es auch schon an FHEM. Auf den Raspberry einloggen und mit

sudo hcitool lescan

mal schauen ob der Sensor erkannt wird. In der Ausgabe müsste dann sowas erscheinen:

C4:7C:8D:12:34:56 Flower care
C4:C7:8D:65:43:21 Flower mate

Wenn irgendwo Flower Care oder Flower mate  hinter den Adressen steht, dann ist der Pflanzensensor erreichbar. Die Mac-Adresse muss kopiert werden, um sie später in FHEM zu benutzen. Also hier z.B.: C4:7C:8D:12:34:56 aufschreiben.

Dann im Browser FHEM öffnen und wie immer erstmal updaten. Dazu einfach in das (Command-) Feld oben update eintippen gefolgt von druck auf die – Taste. Wenn das Update fertig ist einmal mit shutdown restart + FHEM neu starten.

Dann den Pflanzensensor mit FHEM koppeln:
In das Commandfeld

define "NAME" XiaomiFlowerSens "MAC-ADRESSE"

und mit den eigenen Werten ersetzen. Also z.B.:

define Pflanze1 XiaomiFlowerSens C4:7C:8D:12:34:56

Diese Anweisung erstellt ein XiaomiFlowerSens Device mit dem Namen Pflanze1 und der Bluetooth MAC-Adresse C4:7C:8D:12:34:56.

Um später die Daten auch werten zu können muss aktuell noch das anlegen eines Logfiles „von Hand“ erfolgen. Dazu einfach noch mit

define FileLog_pflanze1 FileLog ./log/pflanze1-%Y.log pflanze1

das Logfile erstellen. Dann kann man später aus den dort eingetragenen Werten eine Grafik erstellen lassen. Dann noch mit

attr Pflanze1 event-min-interval state:3600,battery:3600,batteryLevel:3600,temperature:600,moisture:600,fertility:600,lux:300

attr Pflanze1 event-on-change-reading state

attr Pflanze1 event-on-update-reading .*

das Zumüllen des Logfiles verhindern.

 

 

Der XIAOMI Mi Pflanzensensor wird übrigens in Wirklichkeit von Huahuacaocao hergestellt.

Quellen:

https://blog.moneybag.de/fhem-xiaomi-pflanzensensor-feuchtigkeit-helligkeit-temperatur-per-bluetooth-messen/

http://files.xiaomi-mi.com/files/plants_monitor/Plants_monitor-EN.pdf

Werbeanzeigen

BOSCH Küchenmaschine stoppt nach 1 Sekunde

Fehler:

Eine BOSCH Küchenmaschine funktioniert nicht mehr. Nach dem Einschalten/Starten dreht sich der Motor kurz (ca. 1-3 Sekunden) und schaltet dann ab. Dieses Phänomen kann man beliebig oft wiederholen.

Lösung:

Eine kleine Spule verweigert die Zusammenarbeit. Wenn man den „Arm“ der Küchenmaschine zerlegt, stößt man auf eine Platine direkt am Getriebe in einem extra verschraubte Gehäuse. Dort ist eine Spule verbaut die von weitem Aussieht wie ein zu groß geratender Widerstand. Diese hat eine Festinduktivität von ca. 4,7µH.

Das Teil lässt sich leider schlecht auslöten und so habe ich erstmal fast die Leiterbahn von der Platine gerissen.

Die Defekte Spule lässt sich ersetzen durch:

Induktivität axial bedrahtet 4700 µH 74.5 Ω 55 mA LGA0510-4700 1 St.
Teile-Nr.: LGA0510-4700 |  EAN: 2050003713368

Kostenpunkt: unter 0,15€

Oder, wenn man die Hülse herausgerissen hat:

Drossel radial bedrahtet Rastermaß 5 mm 4.7 mH 53 Ω 0.07 A 1 St.
Teile-Nr.: 535508 |  EAN: 2050000173486

Kostenpunkt: unter 1€

Wenn man die axial bedrahtete Version nimmt, muss man Sie genauso Hochkant einbauen wie das Original, wenn man die radial bedrahtete Version nimmt, einfach aufstecken wie jedes andere Bauteil auch.

Quelle/Hilfe gefunden bei:

http://gernot-walzl.at/WordPress/?p=106

Outlook startet nicht mehr: Die Anmeldung wurde abgebrochen, weil Systemressourcen nicht rechtzeitig zur Verfügung standen. Versuchen Sie es erneut.

[WIN] + [E] gleichzeitig drücken -> In der Adressleiste eingeben:

C:\Benutzer\*Name*\AppData\Roaming\Microsoft\Outlook

Die Dateien mit der Endung *.xml und *.srs (z.B. Outlook.xml und Outlook.srs) umbenennen in OutlookBACKUP.xml und OutlookBACKUP.srs, danach Outlook neu starten.

Outlook startet nicht mehr: Die Anmeldung wurde abgebrochen, weil Systemressourcen nicht rechtzeitig zur Verfügung standen. Versuchen Sie es erneut. weiterlesen

Windows Update Error 0x80070003

Das Update auf Windows 10 Anniversary Update 1607 brach immer mit dem Fehlercode: 0x80070003 ab und konnte nicht installiert werden. Der Fehlercode 0x80070003 steht für ERROR_PATH_NOT_FOUND -> der Pfad zu einer angegebenen Datei wird nicht gefunden. Die gängigen Vorschläge zur Reparatur des Windows Update Mechanismus waren alle erfolglos. In den Setuplogs war der Fehler dann aber zu finden: Der Pfad zu wimmount.sys stimmte nicht und daher konnte die Datei nicht gefunden werden. (Wenn man der Fehlermeldung diese Information noch hinzugefügt hätte, wäre Stunden-/Tagelanges Ursachenforschen und Rumdoktoren  erspart geblieben).

Einfach in der Registry:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WIMMount\ImagePath

den Pfad wieder zurück auf:

system32\drivers\wimmount.sys

ändern – und schon funktionier das Update wieder.

Windows Update Error 0x80070003 weiterlesen

Netzwerk unter Win10 in Heimnetzwerk oder öffentliches Netzwerk ändern

  • Gleichzeitig <Win> + <i> Tasten drücken
    (Oderüber das Startmenü die Einstellungen öffnen)
  • Auf „Netzwerk und Internet“ klicken
  • Links auf Ethernet (oder WLAN) klicken
  • Rechts auf die Verbindung klicken
  • Die Option „Dieser PC soll gefunden werden“ stellt das Netzwerk ein:
    • Aus: öffentliches Netzwerk
    • Ein: Heimnetzwerk

 

Netzwerk unter Win10 in Heimnetzwerk oder öffentliches Netzwerk ändern weiterlesen

AVM Fritz!Box Weboberfläche nicht mehr erreichbar

Wenn die Weboberfläche der Fritz!Box nicht mehr erreichbar ist, kann das daran liegen, dass Kaspersky Internet Security 2016 den Zugriff fälschlicherweise sperrt. Kaspersky vorrübergehend zu deaktivieren oder zu beenden hilft in diesem Fall nicht weiter. Aber man kann verschiedene Dinge ausprobieren:

Falls man über http://fritz.box nicht mehr auf die Fritz!Box zugreifen kann kann man es über die Standard-IP Adresse 192.168.178.1 versuchen:

In den Werkseinstellungen verwendet die FRITZ!Box die IP-Adresse 192.168.178.1 (Subnetzmaske 255.255.255.0) und vergibt IP-Adressen von xxx.20 bis xxx.200.

Falls das nicht funktioniert, kann man die Fritz!Box über die Notfall-IP Adresse 169.254.1.1 erreichen.

Benutzeroberfläche über „Notfall-IP“ aufrufen
Vorbereitungen:
Ziehen Sie alle Netzwerkkabel von den LAN-Anschlüssen der FRITZ!Box ab. (Drücken Sie evtl. die WLAN-Taste an der FRITZ!Box, um das WLAN-Funknetz abzuschalten.
Die WLAN-LED beginnt zu blinken. Sobald die WLAN-LED erlischt, ist das WLAN-Funknetz abgeschaltet.)
Verbinden Sie einen Computer über ein Netzwerkkabel mit einem LAN-Anschluss der FRITZ!Box (Am besten LAN 2).

Benutzeroberfläche der FRITZ!Box aufrufen:
Rufen Sie an dem mit der FRITZ!Box verbundenen Computer im Internetbrowser die Adresse 169.254.1.1 auf.
Wenn die Benutzeroberfläche der FRITZ!Box nicht angezeigt wird:
Weisen Sie dem Netzwerkadapter, der mit der FRITZ!Box verbundenen ist, die IP-Adresse 169.254.1.2 zu.
Rufen Sie an dem mit der FRITZ!Box verbundenen Computer im Internetbrowser erneut die Adresse 169.254.1.1 auf.

 

Alte Fritzboxen haben evtl. noch die Notfall-IP:  192.168.178.254


Quellen:

https://avm.de/service/fritzbox/fritzbox-7270/wissensdatenbank/publication/show/245_Benutzeroberflaeche-der-FRITZ-Box-nicht-aufrufbar/
https://avm.de/service/fritzbox/fritzbox-7390/wissensdatenbank/publication/show/374_Benutzeroberflaeche-im-IP-Client-bzw-WLAN-Repeater-Betrieb-aufrufen-wenn-IP-Adresse-unbekannt/

 

 

 

 

 

 

 

 

 

 

 

 

Ende


 

IMAP E-Mail Einstellungen Plesk bei wint.global

Um auf einer bei wint.global aka. Wircon Internetservice GmbH gehosteten und mit Plesk verwalteten Homepage die E-Mails abrufen zu können, müssen im E-Mail Programm folgende Einstellungen vorgenommen werden (meinedomain.de & Co immer mit eigenen Daten ersetzen):

Outlook 2013:

Vorbereitung:  Zertifikatsdomainnamen herausfinden: Diesen findet man in der Adressleiste des Browsers, wenn man in Plesk eingeloggt ist.
Bspw.: ha0XsXXX.org-dns.com

Datei -> Konto hinzufügen -> Manuelle Konfiguration -> POP oder IMAP ->

Ihr Name:  Ihr Name
E-Mail Adresse: meineemailadresse@meinedomain.de

Kontotyp: IMAP
Posteingangsserver: ha0XsXXX.org-dns.com (wie oben beschrieben herauszufinden)
Postausgangsserver (SMTP): ha0XsXXX.org-dns.com

Benutzername: meineemailadresse@meinedomain.de
Kennwort: meinpasswort

Dann unten rechts auf „Weitere Einstellungen“ klicken. Im Tab: Postausgangsserver den Haken bei „Der Postausgangsserver (SMTP) erfordert Authentifizierung“ setzten. Im Tab: Erweitert die Verschlüsselung von „Keine“ auf „SSL“ ändern und den SMTP-Port noch auf 465 ändern.

Mit OK das Menü verlassen und den Einrichtungsassistenten verlassen.

Dann wieder in Outlook über Datei >Kontoeinstellungen > Kontoeinstellungen > Doppelklick auf das E-Mail-Konto > Weitere Einstellungen > Erweitert und im Stammordnerpfad INBOX eintragen. Wenn man das sofort bei der Einrichtung im Assistenten macht, ist Outlook bei mir abgestürzt 😦

Dann legt Outlook zwei Ordner (Gesendete Elemente & Gelöschte Elemente) an.

Jetzt muss man sich ins webmail einloggen und unter Einstellungen -> Ordner die beiden Ordner noch verknüpfen.

Danach kann man in Outlook die beiden (jetzt doppelten) Ordner SENT und TRASH löschen. Sonst schnappt sich ein anderes E-Mail Programm bei der Einrichtung die falschen Ordner. Warum Outlook 2013 so doof ist und nicht die richtigen Ordner akzeptiert und bei der Ersteinrichtung abstürzt ist mir nicht bekannt, ärgert mich aber extrem.

 

iPhone:

Benutzername: meineemailadresse@meinedomain.de
Passwort: meinpasswort
IMAP Posteingangsserver: meinedomain.de (oder wie oben beschrieben z.B.: ha0XsXXX.org-dns.com )
SMTP Postausgangsserver: meinedomain.de (Server erfordert eine Authentifizierung)

SSL Verschlüsselte Mailserverports :
IMAPS: 993
SMTPS: 465
(Das sind die Standardports, welche bei Aktivierung von SSL auch automatisch gewählt werden)
(Für nicht Synchrone POP3 kommunikation -> POP3S: 995)

Bei der Einrichtung der E-Mail Adressen auf einem iPhone muss man die Fehlermeldungen ignorieren, trotzdem speichern und SSL nachträglich aktivieren und wieder die Fehlermeldung ignoieren und speichern. (Es scheint als müsse das Telefon erst die Zertifkate synchronisiern oder sowas, nach dem speichern funktioniert die verschlüsselte Verbindung problemlos.) Dann müssen die Ordner unter Erweitert -> Postfachverhalten noch angepasst werden.

Webmail erreicht man über:

webmail.meinedomain.de

Als Webmailoption und Mailserver hat mir „Roundcube“ besser gefallen als „Horde“, aber das ist Geschmackssache. Nach der Umstellung muss man kurz (etwas) warten, sonst werden die Ordner beim Einrichten im Mailprogramm nicht richtig synchronisiert. Dies sollte auch vor der Einrichtung geschehen.

Als Fallbackoption gibt es noch die unverschlüsselten Serverports:
IMAP: 143
POP3: 110
SMTP: 25

 

Eigentlich funktioniert auch Autodiscovery für die eignen Domains, aber dann gibt es Fehlermeldungen beim SSL-Zertifikat.

 

 

 

 

 

 

 

 

 

.

 

.ENDE

Windows 10 Startmenü funktioniert nicht mehr

Fehlerhafte Log-Datei löschen

In diesem Fall war eine fehlerhafte bzw. beschädigte EDB-Log-Datei für das Problem mit dem Startmenü verantwortlich. Um das Startmenü wieder bedienen zu können, muss die Log-Datei gelöscht werden:

  1. Windows Explorer öffnen ([WIN-Taste] + [E] gleichzeitig drücken) und den Pfad C:\Users\EigenerName\AppData\Local\TileDataLayer\Database\
    öffnen (EigenerName muss mit dem Windows-Benutzernamen ersetzt werden, auf einigen Systemen kann statt C:\Users\.. die deutsche Variante C:\Benutzer\.. nötig sein).
  2. Nun die Datei
    EDB00001.log
    löschen (statt der 1 kann auch eine andere Zahl am Ende stehen).
  3. Den Computer neu starten:
    Rechtsklick mit der Maus auf das aktuell noch nutzlose Windows Startmenü, im sich öffnenden Menü auf „Herunterfahren oder abmelden“ -> „Neu starten“ klicken.

Kaspersky Testversion für 45 Tage

Um eine aktuelle Kaspersky Internet Security Version zu erhalten, die statt der 30 Tägigen kostenlosen Probezeit eine 45 Tägige kostenlose Probezeit enthält, einfach über diesen Link den Installer für die erweiterte Testversion herunterladen:

https://goo.gl/PIujQF

oder (falls der Link abgelaufen ist):

Kaspersky 45 Tage Installer (ZIP gepackt)

Und schon hat man 45 Tage kostenloses Top Antivirus.

Das funktioniert auch, wenn man vorher schon die 30 Tägige Version installiert hat. Einfach drüber installieren und weitere 45 Tage kostenloses Kaspersky Internet Security bekommen.

Automatischer Login bei Windows

Um nicht bei jedem Start von Windows ein Passwort eingeben zu müssen, kann dies auch abgeschaltet werden:

Gleichzeitig [ WIN ] + R drücken um die Kommandozeile zu öffnen. In das Feld:

control userpasswords2

eintippen und anschließend die Enter-Taste drücken, um die Eingabeaufforderung zu öffnen.

Hier muss der Haken vor „Benutzer müssen Benutzernamen und Kennwort eingeben“ entfernt werden und  mit klick auf <OK> betätigt werden. Man muss dann das aktuelle Windows-Passwort eingeben und mit <OK> bestätigen.

Damit ist der automatische Login aktiviert.


Quelle:

Wie war das nochmal? Das Problem kenn ich doch!